]> Git Repo - buildroot-mgba.git/blob - package/tcl/tcl.mk
tcl: specify ln -sf to remove existing destination file
[buildroot-mgba.git] / package / tcl / tcl.mk
1 ################################################################################
2 #
3 # tcl
4 #
5 ################################################################################
6
7 TCL_VERSION_MAJOR = 8.4
8 TCL_VERSION_MINOR = 19
9 TCL_VERSION = $(TCL_VERSION_MAJOR).$(TCL_VERSION_MINOR)
10 TCL_SOURCE = tcl$(TCL_VERSION)-src.tar.gz
11 TCL_SITE = http://downloads.sourceforge.net/project/tcl/Tcl/$(TCL_VERSION)
12 TCL_LICENSE = tcl license
13 TCL_LICENSE_FILES = license.terms
14 TCL_SUBDIR = unix
15 TCL_INSTALL_STAGING = YES
16 TCL_CONF_OPT = \
17                 --disable-symbols \
18                 --disable-langinfo \
19                 --disable-framework
20
21 HOST_TCL_CONF_OPT = \
22                 --disable-symbols \
23                 --disable-langinfo \
24                 --disable-framework
25
26 ifeq ($(BR2_PACKAGE_TCL_DEL_ENCODINGS),y)
27 define TCL_REMOVE_ENCODINGS
28         rm -rf $(TARGET_DIR)/usr/lib/tcl$(TCL_VERSION_MAJOR)/encoding/*
29 endef
30 TCL_POST_INSTALL_TARGET_HOOKS += TCL_REMOVE_ENCODINGS
31 endif
32
33 ifeq ($(BR2_PACKAGE_TCL_SHLIB_ONLY),y)
34 define TCL_REMOVE_TCLSH
35         rm -f $(TARGET_DIR)/usr/bin/tclsh$(TCL_VERSION_MAJOR)
36 endef
37 TCL_POST_INSTALL_TARGET_HOOKS += TCL_REMOVE_TCLSH
38 else
39 define TCL_SYMLINK_TCLSH
40         ln -sf tclsh$(TCL_VERSION_MAJOR) $(TARGET_DIR)/usr/bin/tclsh
41 endef
42 TCL_POST_INSTALL_TARGET_HOOKS += TCL_SYMLINK_TCLSH
43 endif
44
45 # library get installed read only, so strip fails
46 define TCL_FIXUP_RO_LIB
47         chmod +w $(TARGET_DIR)/usr/lib/libtcl*
48 endef
49
50 TCL_POST_INSTALL_TARGET_HOOKS += TCL_FIXUP_RO_LIB
51
52 $(eval $(autotools-package))
53 $(eval $(host-autotools-package))
This page took 0.030708 seconds and 4 git commands to generate.