]> Git Repo - buildroot-mgba.git/blob - package/dropwatch/dropwatch.mk
dropwatch: fix static link
[buildroot-mgba.git] / package / dropwatch / dropwatch.mk
1 ################################################################################
2 #
3 # dropwatch
4 #
5 ################################################################################
6
7 DROPWATCH_VERSION = 7c33d8a8ed105b07a46b55d71d93b36ed34c16db
8 DROPWATCH_SITE = git://git.infradead.org/users/nhorman/dropwatch.git
9 DROPWATCH_DEPENDENCIES = binutils libnl readline host-pkgconf
10 DROPWATCH_LICENSE = GPL-2.0
11 DROPWATCH_LICENSE_FILES = COPYING
12
13 # libbfd may be linked to libintl
14 # Ugly... but LDLIBS are hardcoded anyway
15 DROPWATCH_LDLIBS = \
16         -lbfd -lreadline -lnl-3 -lnl-genl-3 -lpthread -lncurses -lm
17
18 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
19 DROPWATCH_LDLIBS += -lintl
20 endif
21
22 define DROPWATCH_BUILD_CMDS
23         $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
24                 LDLIBS="$(DROPWATCH_LDLIBS)" build
25 endef
26
27 define DROPWATCH_INSTALL_TARGET_CMDS
28         $(INSTALL) -D -m 0755 $(@D)/src/dropwatch \
29                 $(TARGET_DIR)/usr/bin/dropwatch
30 endef
31
32 $(eval $(generic-package))
This page took 0.030363 seconds and 4 git commands to generate.