]> Git Repo - buildroot-mgba.git/blob - package/mongrel2/mongrel2.mk
package/docker-containerd: convert to golang infrastructure
[buildroot-mgba.git] / package / mongrel2 / mongrel2.mk
1 ################################################################################
2 #
3 # mongrel2
4 #
5 ################################################################################
6
7 MONGREL2_VERSION = 1.9.2
8 MONGREL2_SOURCE = mongrel2-v$(MONGREL2_VERSION).tar.bz2
9 # Do not use the github helper here, the generated tarball is *NOT* the same
10 # as the one uploaded by upstream for the release.
11 MONGREL2_SITE = https://github.com/mongrel2/mongrel2/releases/download/$(MONGREL2_VERSION)
12 MONGREL2_LICENSE = BSD-3-Clause
13 MONGREL2_LICENSE_FILES = LICENSE
14 MONGREL2_DEPENDENCIES = sqlite zeromq
15
16 define MONGREL2_POLARSSL_DISABLE_ASM
17         $(SED) '/^#define POLARSSL_HAVE_ASM/d' $(@D)/src/polarssl/include/polarssl/config.h
18 endef
19
20 # ARM in thumb mode breaks debugging with asm optimizations
21 # Microblaze asm optimizations are broken in general
22 # MIPS R6 asm is not yet supported
23 ifeq ($(BR2_ENABLE_DEBUG)$(BR2_ARM_INSTRUCTIONS_THUMB)$(BR2_ARM_INSTRUCTIONS_THUMB2),yy)
24 MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
25 else ifeq ($(BR2_microblaze),y)
26 MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
27 else ifeq ($(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6),y)
28 MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
29 endif
30
31 define MONGREL2_BUILD_CMDS
32         $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
33                 PREFIX=/usr all
34 endef
35
36 define MONGREL2_INSTALL_TARGET_CMDS
37         $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
38                 PREFIX=/usr DESTDIR=$(TARGET_DIR) install
39 endef
40
41 $(eval $(generic-package))
This page took 0.037058 seconds and 4 git commands to generate.