]> Git Repo - buildroot-mgba.git/blob - package/avahi/avahi.mk
avahi: add missing dependency on host-gettext
[buildroot-mgba.git] / package / avahi / avahi.mk
1 #############################################################
2 #
3 # avahi (zeroconf implementation)
4 #
5 #############################################################
6 #
7 # This program is free software; you can redistribute it
8 # and/or modify it under the terms of the GNU Lesser General
9 # Public License as published by the Free Software Foundation
10 # either version 2.1 of the License, or (at your option) any
11 # later version.
12
13 AVAHI_VERSION = 0.6.31
14 AVAHI_SOURCE = avahi-$(AVAHI_VERSION).tar.gz
15 AVAHI_SITE = http://www.avahi.org/download/
16 AVAHI_LICENSE = LGPLv2.1+
17 AVAHI_LICENSE_FILES = LICENSE
18 AVAHI_INSTALL_STAGING = YES
19
20 AVAHI_CONF_ENV = ac_cv_func_strtod=yes \
21                 ac_fsusage_space=yes \
22                 fu_cv_sys_stat_statfs2_bsize=yes \
23                 ac_cv_func_closedir_void=no \
24                 ac_cv_func_getloadavg=no \
25                 ac_cv_lib_util_getloadavg=no \
26                 ac_cv_lib_getloadavg_getloadavg=no \
27                 ac_cv_func_getgroups=yes \
28                 ac_cv_func_getgroups_works=yes \
29                 ac_cv_func_chown_works=yes \
30                 ac_cv_have_decl_euidaccess=no \
31                 ac_cv_func_euidaccess=no \
32                 ac_cv_have_decl_strnlen=yes \
33                 ac_cv_func_strnlen_working=yes \
34                 ac_cv_func_lstat_dereferences_slashed_symlink=yes \
35                 ac_cv_func_lstat_empty_string_bug=no \
36                 ac_cv_func_stat_empty_string_bug=no \
37                 vb_cv_func_rename_trailing_slash_bug=no \
38                 ac_cv_have_decl_nanosleep=yes \
39                 jm_cv_func_nanosleep_works=yes \
40                 gl_cv_func_working_utimes=yes \
41                 ac_cv_func_utime_null=yes \
42                 ac_cv_have_decl_strerror_r=yes \
43                 ac_cv_func_strerror_r_char_p=no \
44                 jm_cv_func_svid_putenv=yes \
45                 ac_cv_func_getcwd_null=yes \
46                 ac_cv_func_getdelim=yes \
47                 ac_cv_func_mkstemp=yes \
48                 utils_cv_func_mkstemp_limitations=no \
49                 utils_cv_func_mkdir_trailing_slash_bug=no \
50                 jm_cv_func_gettimeofday_clobber=no \
51                 am_cv_func_working_getline=yes \
52                 gl_cv_func_working_readdir=yes \
53                 jm_ac_cv_func_link_follows_symlink=no \
54                 utils_cv_localtime_cache=no \
55                 ac_cv_struct_st_mtim_nsec=no \
56                 gl_cv_func_tzset_clobber=no \
57                 gl_cv_func_getcwd_null=yes \
58                 gl_cv_func_getcwd_path_max=yes \
59                 ac_cv_func_fnmatch_gnu=yes \
60                 am_getline_needs_run_time_check=no \
61                 am_cv_func_working_getline=yes \
62                 gl_cv_func_mkdir_trailing_slash_bug=no \
63                 gl_cv_func_mkstemp_limitations=no \
64                 ac_cv_func_working_mktime=yes \
65                 jm_cv_func_working_re_compile_pattern=yes \
66                 ac_use_included_regex=no \
67                 avahi_cv_sys_cxx_works=yes \
68                 DATADIRNAME=share
69
70 AVAHI_CONF_OPT = --localstatedir=/var \
71                 --disable-qt3 \
72                 --disable-qt4 \
73                 --disable-gdbm \
74                 --disable-python-dbus \
75                 --disable-pygtk \
76                 --disable-gtk3 \
77                 --disable-mono \
78                 --disable-monodoc \
79                 --disable-stack-protector \
80                 --with-distro=none \
81                 $(if $(BR2_HAVE_DOCUMENTATION),--enable,--disable)-manpages \
82                 $(if $(BR2_PACKAGE_AVAHI_AUTOIPD),--enable,--disable)-autoipd \
83                 --with-avahi-user=default \
84                 --with-avahi-group=default \
85                 --with-autoipd-user=default \
86                 --with-autoipd-group=default
87
88 AVAHI_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-intltool \
89        host-pkgconf host-gettext
90
91 ifneq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_AVAHI_AUTOIPD),)
92 AVAHI_DEPENDENCIES += libdaemon
93 else
94 AVAHI_CONF_OPT += --disable-libdaemon
95 endif
96
97 ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
98 AVAHI_DEPENDENCIES += expat
99 AVAHI_CONF_OPT += --with-xml=expat
100 else
101 AVAHI_CONF_OPT += --with-xml=none
102 endif
103
104 ifeq ($(BR2_PACKAGE_DBUS),y)
105 AVAHI_DEPENDENCIES += dbus
106 else
107 AVAHI_CONF_OPT += --disable-dbus
108 endif
109
110 ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
111 AVAHI_DEPENDENCIES += libglib2
112 else
113 AVAHI_CONF_OPT += --disable-glib --disable-gobject
114 endif
115
116 ifeq ($(BR2_PACKAGE_LIBGLADE),y)
117 AVAHI_DEPENDENCIES += libglade
118 else
119 AVAHI_CONF_OPT += --disable-gtk
120 endif
121
122 ifeq ($(BR2_PACKAGE_PYTHON),y)
123 AVAHI_CONF_ENV += am_cv_pathless_PYTHON=python \
124                 am_cv_path_PYTHON=$(PYTHON_TARGET_BINARY) \
125                 am_cv_python_version=$(PYTHON_VERSION) \
126                 am_cv_python_platform=linux2 \
127                 am_cv_python_pythondir=/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages \
128                 am_cv_python_pyexecdir=/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages \
129                 py_cv_mod_socket_=yes
130
131 AVAHI_DEPENDENCIES += python
132 AVAHI_CONF_OPT += --enable-python
133 else
134 AVAHI_CONF_OPT += --disable-python
135 endif
136
137 ifeq ($(BR2_PACKAGE_GETTEXT),y)
138 AVAHI_DEPENDENCIES += gettext
139 AVAHI_MAKE_OPT = LIBS=-lintl
140 endif
141
142 define AVAHI_REMOVE_INITSCRIPT
143         rm -rf $(TARGET_DIR)/etc/init.d/avahi-*
144 endef
145
146 AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_REMOVE_INITSCRIPT
147
148 define AVAHI_INSTALL_AUTOIPD
149         rm -rf $(TARGET_DIR)/etc/dhcp3/
150         $(INSTALL) -D -m 0755 package/avahi/busybox-udhcpc-default.script $(TARGET_DIR)/usr/share/udhcpc/default.script
151         $(INSTALL) -m 0755 package/avahi/S05avahi-setup.sh $(TARGET_DIR)/etc/init.d/
152         rm -f $(TARGET_DIR)/var/lib/avahi-autoipd
153         $(INSTALL) -d -m 0755 $(TARGET_DIR)/var/lib
154         ln -sf /tmp/avahi-autoipd $(TARGET_DIR)/var/lib/avahi-autoipd
155 endef
156
157 ifeq ($(BR2_PACKAGE_AVAHI_AUTOIPD),y)
158 AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_AUTOIPD
159 endif
160
161 define AVAHI_INSTALL_DAEMON_INITSCRIPT
162         $(INSTALL) -m 0755 package/avahi/S50avahi-daemon $(TARGET_DIR)/etc/init.d/
163 endef
164
165 ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
166 AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_DAEMON_INITSCRIPT
167 endif
168
169 $(eval $(autotools-package))
This page took 0.039967 seconds and 4 git commands to generate.