2 # -*- mode: makefile; coding: utf-8 -*-
4 #DEB_MAKE_CHECK_TARGET = test_bitcoin
6 # $(if $(filter nocheck,$(DEB_BUILD_OPTIONS)),,src/test_bitcoin)
8 DEB_INSTALL_EXAMPLES_bitcoind += debian/examples/*
9 DEB_INSTALL_MANPAGES_bitcoind += debian/manpages/*
14 override_dh_auto_build:
15 cd src; $(MAKE) -f makefile.unix bitcoind
18 override_dh_auto_clean:
19 if [ -f Makefile ]; then $(MAKE) clean; else rm -rf build/; rm -f bitcoin-qt; fi
20 cd src; $(MAKE) -f makefile.unix clean
22 override_dh_auto_configure:
23 qmake bitcoin-qt.pro USE_QRCODE=1
25 override_dh_auto_test:
26 cd src; $(MAKE) -f makefile.unix test_bitcoin
29 # Ensure wrapper is set executable
30 binary-post-install/bitcoind:
31 chmod +x $(cdbs_curdestdir)usr/bin/bitcoind
32 binary-post-install/bitcoin-qt:
33 chmod +x $(cdbs_curdestdir)usr/bin/bitcoin-qt