]> Git Repo - linux.git/commit
seq_file: Rename seq_overflow() to seq_has_overflowed() and make public
authorJoe Perches <[email protected]>
Mon, 29 Sep 2014 23:08:21 +0000 (16:08 -0700)
committerSteven Rostedt <[email protected]>
Thu, 30 Oct 2014 00:26:06 +0000 (20:26 -0400)
commit1f33c41c03daece85a84b8dcea5733f3efe3e2b0
treedc20bd3893f3756d30c9281c2aafc5c1170bdaee
parentf114040e3ea6e07372334ade75d1ee0775c355e1
seq_file: Rename seq_overflow() to seq_has_overflowed() and make public

The return values of seq_printf/puts/putc are frequently misused.

Start down a path to remove all the return value uses of these
functions.

Move the seq_overflow() to a global inlined function called
seq_has_overflowed() that can be used by the users of seq_file() calls.

Update the documentation to not show return types for seq_printf
et al.  Add a description of seq_has_overflowed().

Link: http://lkml.kernel.org/p/848ac7e3d1c31cddf638a8526fa3c59fa6fdeb8a.1412031505.git.joe@perches.com
Cc: Al Viro <[email protected]>
Signed-off-by: Joe Perches <[email protected]>
[ Reworked the original patch from Joe ]
Signed-off-by: Steven Rostedt <[email protected]>
Documentation/filesystems/seq_file.txt
fs/seq_file.c
include/linux/seq_file.h
This page took 0.056604 seconds and 4 git commands to generate.