]>
Git Repo - VerusCoin.git/log
Pieter Wuille [Fri, 12 Sep 2014 14:37:53 +0000 (16:37 +0200)]
Avoid reject message feedback loops
Wladimir J. van der Laan [Thu, 11 Sep 2014 12:46:20 +0000 (14:46 +0200)]
Merge pull request #4885
aa3c697 Store fewer orphan tx by default, add -maxorphantx option (Gavin Andresen)
c74332c Stricter handling of orphan transactions (Gavin Andresen)
Wladimir J. van der Laan [Thu, 11 Sep 2014 06:56:23 +0000 (08:56 +0200)]
Merge pull request #4892
e982b57 Use explicit fflush() instead of setvbuf() (Adam Weiss)
Gavin Andresen [Wed, 10 Sep 2014 18:08:03 +0000 (14:08 -0400)]
Store fewer orphan tx by default, add -maxorphantx option
There is no reason to store thousands of orphan transactions;
normally an orphan's parents will either be broadcast or
mined reasonably quickly.
This pull drops the maximum number of orphans from 10,000 down
to 100, and adds a command-line option (-maxorphantx) that is
just like -maxorphanblocks to override the default.
Gavin Andresen [Thu, 28 Aug 2014 17:23:24 +0000 (13:23 -0400)]
Stricter handling of orphan transactions
Prevent denial-of-service attacks by banning
peers that send us invalid orphan transactions
and only storing orphan transactions given to
us by a peer while the peer is connected.
Adam Weiss [Wed, 10 Sep 2014 16:26:59 +0000 (12:26 -0400)]
Use explicit fflush() instead of setvbuf()
Flushing after every line when printing to console is desirable when
running with systemd but setvbuf() has slightly different semantics
on Windows that causes warnings. Just do an explicit fflush() after
each line print to console instead.
Gavin Andresen [Tue, 9 Sep 2014 18:01:11 +0000 (14:01 -0400)]
Fix crashing bug caused by orphan(s) with duplicate prevout.hash
Wladimir J. van der Laan [Wed, 10 Sep 2014 14:47:40 +0000 (16:47 +0200)]
Merge pull request #4878
540ac45 Avoid returning many "inv" orphans (Jeff Garzik)
d4168c8 Limit CNode::mapAskFor (Wladimir J. van der Laan)
Wladimir J. van der Laan [Wed, 10 Sep 2014 12:29:16 +0000 (14:29 +0200)]
Merge pull request #4623
e84843c Broken addresses on command line no longer trigger testnet. (Ross Nicoll)
Wladimir J. van der Laan [Wed, 10 Sep 2014 10:51:56 +0000 (12:51 +0200)]
Merge pull request #4755
c1e433b Rename scriptutils.o to wallet_ismine.o (jtimon)
8b59a3d Move CAffectedKeysVisitor to wallet.cpp (remove ExtractAffectedKeys) (jtimon)
0d2fa14 Move scriptutils.o to wallet (jtimon)
jtimon [Sat, 30 Aug 2014 11:40:37 +0000 (13:40 +0200)]
Rename scriptutils.o to wallet_ismine.o
jtimon [Wed, 27 Aug 2014 15:46:30 +0000 (17:46 +0200)]
Move CAffectedKeysVisitor to wallet.cpp (remove ExtractAffectedKeys)
jtimon [Fri, 29 Aug 2014 20:07:39 +0000 (22:07 +0200)]
Move scriptutils.o to wallet
Wladimir J. van der Laan [Wed, 10 Sep 2014 08:55:30 +0000 (10:55 +0200)]
Merge pull request #4874
21f139b qt: fix tablet crash. closes #4854. (Cory Fields)
Wladimir J. van der Laan [Wed, 10 Sep 2014 08:11:04 +0000 (10:11 +0200)]
Merge pull request #4867
a95b119 qt: Remove thousands separators after decimal point (Wladimir J. van der Laan)
Pieter Wuille [Tue, 9 Sep 2014 23:38:43 +0000 (01:38 +0200)]
Merge pull request #4822
629d75f Combine CCoinsViewCache's HaveCoins and const GetCoins into AccessCoins. (Pieter Wuille)
Pieter Wuille [Tue, 9 Sep 2014 23:36:41 +0000 (01:36 +0200)]
Merge pull request #4882
faadbe1 remove unneeded cast in rpcmisc.cpp (Philip Kaufmann)
Philip Kaufmann [Tue, 9 Sep 2014 08:09:59 +0000 (10:09 +0200)]
remove unneeded cast in rpcmisc.cpp
Pieter Wuille [Tue, 9 Sep 2014 14:39:35 +0000 (16:39 +0200)]
Merge pull request #4868
2c2cc5d Remove some unnecessary c_strs() in logging and the GUI (Philip Kaufmann)
f7d0a86 netbase: Use .data() instead of .c_str() on binary string (Wladimir J. van der Laan)
Philip Kaufmann [Mon, 8 Sep 2014 10:25:52 +0000 (12:25 +0200)]
Remove some unnecessary c_strs() in logging and the GUI
Includes `core: remove unneeded c_str() / Qt: replace c_str() with Qt code`
by P. Kaufmann.
Jeff Garzik [Tue, 9 Sep 2014 07:26:52 +0000 (09:26 +0200)]
Avoid returning many "inv" orphans
Wladimir J. van der Laan [Tue, 9 Sep 2014 07:18:05 +0000 (09:18 +0200)]
Limit CNode::mapAskFor
Tighten resource constraints on CNode.
Wladimir J. van der Laan [Tue, 9 Sep 2014 07:13:38 +0000 (09:13 +0200)]
Merge pull request #4873
89d91f6 Avoid repeated lookups in mapOrphanTransactions and mapOrphanTransactionsByPrev (Wladimir J. van der Laan)
Cory Fields [Sat, 6 Sep 2014 02:55:54 +0000 (22:55 -0400)]
qt: fix tablet crash. closes #4854.
This backports the relevant parts of:
https://codereview.qt-project.org/#/c/82689/
Pieter Wuille [Mon, 8 Sep 2014 18:34:01 +0000 (20:34 +0200)]
Merge pull request #4754
e088d65 Separate script/sign (jtimon)
9294a4b Separate CScriptCompressor (jtimon)
c4408a6 Separate script/standard (jtimon)
da03e6e Separate script/interpreter (jtimon)
cbd22a5 Move CScript class and dependencies to script/script (jtimon)
86dbeea Rename script.h/.cpp to scriptutils.h/.cpp (plus remove duplicated includes) (jtimon)
Rebased-by: Pieter Wuille
jtimon [Wed, 27 Aug 2014 15:22:33 +0000 (17:22 +0200)]
Separate script/sign
jtimon [Wed, 20 Aug 2014 16:33:30 +0000 (18:33 +0200)]
Separate CScriptCompressor
jtimon [Sat, 23 Aug 2014 01:35:51 +0000 (03:35 +0200)]
Separate script/standard
jtimon [Wed, 27 Aug 2014 18:11:41 +0000 (20:11 +0200)]
Separate script/interpreter
jtimon [Wed, 20 Aug 2014 15:37:40 +0000 (17:37 +0200)]
Move CScript class and dependencies to script/script
jtimon [Thu, 14 Aug 2014 11:54:05 +0000 (13:54 +0200)]
Rename script.h/.cpp to scriptutils.h/.cpp (plus remove duplicated includes)
Wladimir J. van der Laan [Mon, 8 Sep 2014 15:37:26 +0000 (17:37 +0200)]
Avoid repeated lookups in mapOrphanTransactions and mapOrphanTransactionsByPrev
Pieter Wuille [Mon, 8 Sep 2014 13:13:46 +0000 (15:13 +0200)]
Merge pull request #4865
8e44f2e Clarify 'compressed nor uncompressed' error message (Peter Todd)
Wladimir J. van der Laan [Mon, 8 Sep 2014 10:20:50 +0000 (12:20 +0200)]
netbase: Use .data() instead of .c_str() on binary string
`.c_str()` is only guaranteed to return the data up to the first NUL
character.
Wladimir J. van der Laan [Mon, 8 Sep 2014 09:59:57 +0000 (11:59 +0200)]
Merge pull request #4712
80daee0 [Qt] Call checkBalanceChanged() periodically instead for every updated transaction (Cozz Lovan)
Wladimir J. van der Laan [Mon, 8 Sep 2014 09:05:41 +0000 (11:05 +0200)]
Merge pull request #4697
da2ede2 [Wallet] Improve ReorderTransactions(..) (Cozz Lovan)
Wladimir J. van der Laan [Mon, 8 Sep 2014 08:40:54 +0000 (10:40 +0200)]
qt: Remove thousands separators after decimal point
Revert thousands separators after decimal point, as introduced in #4167.
Wladimir J. van der Laan [Mon, 8 Sep 2014 07:14:10 +0000 (09:14 +0200)]
Merge pull request #4862
45a4baf Add testnet DNS seed of Andreas Schildbach. (Andreas Schildbach)
Peter Todd [Mon, 8 Sep 2014 02:32:57 +0000 (22:32 -0400)]
Clarify 'compressed nor uncompressed' error message
Andreas Schildbach [Sun, 7 Sep 2014 09:11:57 +0000 (11:11 +0200)]
Add testnet DNS seed of Andreas Schildbach.
It runs sipas crawler, but rather than using its custom nameserver implementation it serves a generated zonefile via bind9. The zone always contains 25 IPv4 and 25 IPv6 peers. FWIW, the zone is secured using DNSSEC.
Pieter Wuille [Sat, 6 Sep 2014 19:09:50 +0000 (21:09 +0200)]
Merge pull request #4851
41ef558 univalue: make spaceStr thread-safe (Wladimir J. van der Laan)
Wladimir J. van der Laan [Sat, 6 Sep 2014 08:26:26 +0000 (10:26 +0200)]
Merge pull request #4839
346193b Cleanup messy error messages (R E Broadley)
R E Broadley [Thu, 4 Sep 2014 02:59:20 +0000 (09:59 +0700)]
Cleanup messy error messages
Pieter Wuille [Fri, 5 Sep 2014 20:53:56 +0000 (22:53 +0200)]
Merge pull request #4849
a264e44 remove dup include of foreach.hpp in script.cpp (Philip Kaufmann)
Gavin Andresen [Fri, 5 Sep 2014 14:48:28 +0000 (10:48 -0400)]
Merge pull request #4836 from morcos/fix-make_change
Fix make_change to not create half-satoshis
Gavin Andresen [Wed, 3 Sep 2014 19:07:43 +0000 (15:07 -0400)]
Fix make_change to not create half-satoshis
Wladimir J. van der Laan [Fri, 5 Sep 2014 11:10:39 +0000 (13:10 +0200)]
univalue: make spaceStr thread-safe
Simply add spaces to the existing string instead of using a
temporary.
Fixes #4756.
Teran McKinney [Mon, 18 Aug 2014 19:33:51 +0000 (19:33 +0000)]
Improve readability of CAddrInfo::IsTerrible
- Replaced 86400 with 24*60*60
- Remove references to specific timespans in comments
Github-Pull: #4724
Wladimir J. van der Laan [Fri, 5 Sep 2014 11:33:37 +0000 (13:33 +0200)]
Merge pull request #4850
1ffb99b [Qt] copyright, style and indentation cleanup of Qt tests (Philip Kaufmann)
Philip Kaufmann [Fri, 5 Sep 2014 11:11:11 +0000 (13:11 +0200)]
[Qt] copyright, style and indentation cleanup of Qt tests
Wladimir J. van der Laan [Fri, 5 Sep 2014 10:27:00 +0000 (12:27 +0200)]
Merge pull request #4843
81061ff travis: add osx build (Cory Fields)
e4cf9f8 depends: fix typo in source downloading. Regression from
c897b1e732 . (Cory Fields)
Philip Kaufmann [Fri, 5 Sep 2014 07:49:57 +0000 (09:49 +0200)]
remove dup include of foreach.hpp in script.cpp
Pieter Wuille [Thu, 4 Sep 2014 21:48:01 +0000 (23:48 +0200)]
Merge pull request #4838
1e4f87f Use memcmp for uint256 equality/inequality (Pieter Wuille)
8a41e1e Use boost::unordered_map for mapBlockIndex (Pieter Wuille)
145d5be Introduce BlockMap type for mapBlockIndex (Pieter Wuille)
a0dbe43 checkpoints.cpp depends on main, it can use mapBlockIndex directly (Pieter Wuille)
Cory Fields [Wed, 3 Sep 2014 18:14:01 +0000 (14:14 -0400)]
travis: add osx build
Cory Fields [Thu, 4 Sep 2014 17:12:13 +0000 (13:12 -0400)]
depends: fix typo in source downloading. Regression from
c897b1e732 .
Some sources are renamed after download, since the filenames don't play nice
with (for example) gitian. This fixes the rename.
Needed for OSX build as it renames a file.
Wladimir J. van der Laan [Thu, 4 Sep 2014 14:43:22 +0000 (16:43 +0200)]
Merge pull request #4783
fbe0fca [Qt] minor watch-only changes (Philip Kaufmann)
Wladimir J. van der Laan [Thu, 4 Sep 2014 13:19:55 +0000 (15:19 +0200)]
Merge pull request #4762
399cdbc contrib/linearize: Add feature to set file's timestamp based on block header time. (Jeff Garzik)
8f5a423 contrib/linearize: split block files based on year-month, not just year (Jeff Garzik)
75400a2 contrib/linearize: Guarantee that output is generated in-order (Jeff Garzik)
Jeff Garzik [Sun, 24 Aug 2014 15:37:14 +0000 (11:37 -0400)]
contrib/linearize: Add feature to set file's timestamp based on block header time.
Wladimir J. van der Laan [Thu, 4 Sep 2014 11:31:10 +0000 (13:31 +0200)]
Merge pull request #4833
bbda402 net: Remove MilliSleep from StopNode (Wladimir J. van der Laan)
Wladimir J. van der Laan [Thu, 4 Sep 2014 11:30:29 +0000 (13:30 +0200)]
Merge pull request #4790
9189f5f remove useless millisleep (phantomcircuit)
Wladimir J. van der Laan [Thu, 4 Sep 2014 11:21:05 +0000 (13:21 +0200)]
Merge pull request #4842
fb51e28 Added XML syntax highlighting (himynameismartin)
himynameismartin [Thu, 4 Sep 2014 10:45:28 +0000 (12:45 +0200)]
Added XML syntax highlighting
Pieter Wuille [Thu, 4 Sep 2014 00:03:39 +0000 (02:03 +0200)]
Use memcmp for uint256 equality/inequality
Pieter Wuille [Thu, 4 Sep 2014 00:03:17 +0000 (02:03 +0200)]
Use boost::unordered_map for mapBlockIndex
Pieter Wuille [Thu, 4 Sep 2014 00:02:44 +0000 (02:02 +0200)]
Introduce BlockMap type for mapBlockIndex
Pieter Wuille [Thu, 4 Sep 2014 00:01:10 +0000 (02:01 +0200)]
checkpoints.cpp depends on main, it can use mapBlockIndex directly
Pieter Wuille [Wed, 3 Sep 2014 18:54:10 +0000 (20:54 +0200)]
Merge pull request #4808
3f6540a Rename IMPLEMENT_SERIALIZE to ADD_SERIALIZE_METHODS (Pieter Wuille)
47eb765 Serializer simplifications after IMPLEMENT_SERIALIZE overhaul (Pieter Wuille)
Pieter Wuille [Wed, 3 Sep 2014 18:50:34 +0000 (20:50 +0200)]
Merge pull request #4820
910526d Use OR of respective block flags for masks (Pieter Wuille)
Wladimir J. van der Laan [Wed, 3 Sep 2014 16:29:30 +0000 (18:29 +0200)]
Merge pull request #4671
550d4fa Remove DNS Seeds run by entities which were never well-established. (Matt Corallo)
Pieter Wuille [Tue, 2 Sep 2014 19:21:15 +0000 (21:21 +0200)]
Combine CCoinsViewCache's HaveCoins and const GetCoins into AccessCoins.
The efficient version of CCoinsViewCache::GetCoins only works for known-to-exist
cache entries, requiring a separate HaveCoins call beforehand. This is
inefficient as both perform a hashtable lookup.
Replace the non-mutable GetCoins with AccessCoins, which returns a potentially-NULL
pointer. This also decreases the overloading of GetCoins.
Also replace some copying (inefficient) GetCoins calls with equivalent AccessCoins,
decreasing the copying.
Wladimir J. van der Laan [Wed, 3 Sep 2014 10:20:47 +0000 (12:20 +0200)]
net: Remove MilliSleep from StopNode
I don't understand why it would be there in the first place. This looks
like voodoo, not programming.
Matt Corallo [Sun, 10 Aug 2014 03:57:47 +0000 (20:57 -0700)]
Remove DNS Seeds run by entities which were never well-established.
phantomcircuit [Sat, 30 Aug 2014 01:21:18 +0000 (18:21 -0700)]
remove useless millisleep
reduces time to service requests improving performance
Pieter Wuille [Tue, 2 Sep 2014 16:56:47 +0000 (18:56 +0200)]
Use OR of respective block flags for masks
Pieter Wuille [Tue, 2 Sep 2014 13:11:44 +0000 (15:11 +0200)]
Merge pull request #4812
53efb09 Discover some missing includes (jtimon)
8d5e510 Remove unused function StackString() and class CCoins; (jtimon)
Wladimir J. van der Laan [Tue, 2 Sep 2014 08:07:23 +0000 (10:07 +0200)]
Merge pull request #4810
c0f5d4a Fixing Compiler Error C2466 (ENikS)
Pieter Wuille [Tue, 2 Sep 2014 07:58:09 +0000 (09:58 +0200)]
Rename IMPLEMENT_SERIALIZE to ADD_SERIALIZE_METHODS
jtimon [Sat, 23 Aug 2014 03:09:47 +0000 (05:09 +0200)]
Discover some missing includes
jtimon [Sat, 23 Aug 2014 01:52:54 +0000 (03:52 +0200)]
Remove unused function StackString() and class CCoins;
ENikS [Mon, 1 Sep 2014 23:51:25 +0000 (19:51 -0400)]
Fixing Compiler Error C2466
Pieter Wuille [Mon, 1 Sep 2014 19:36:46 +0000 (21:36 +0200)]
Serializer simplifications after IMPLEMENT_SERIALIZE overhaul
Pieter Wuille [Mon, 1 Sep 2014 19:00:32 +0000 (21:00 +0200)]
Merge pull request #4737
31e9a83 Use CSizeComputer to avoid counting sizes in SerializationOp (Pieter Wuille)
84881f8 rework overhauled serialization methods to non-static (Kamil Domanski)
5d96b4a remove fields of ser_streamplaceholder (Kamil Domanski)
3d796f8 overhaul serialization code (Kamil Domanski)
Wladimir J. van der Laan [Mon, 1 Sep 2014 11:54:02 +0000 (13:54 +0200)]
Merge pull request #4779
093303a add missing header end comments (Philip Kaufmann)
Wladimir J. van der Laan [Mon, 1 Sep 2014 08:28:27 +0000 (10:28 +0200)]
Merge pull request #4767
b144a74 depends: bump miniupnpc to 1.9.
20140701 . (Cory Fields)
f628127 depends: bump openssl to 1.0.1i (Cory Fields)
9f7f504 build: add -DMINIUPNP_STATICLIB for new version (Cory Fields)
Wladimir J. van der Laan [Mon, 1 Sep 2014 08:26:36 +0000 (10:26 +0200)]
Merge pull request #4780
4d04492 add missing copyright headers (Philip Kaufmann)
Wladimir J. van der Laan [Mon, 1 Sep 2014 08:10:51 +0000 (10:10 +0200)]
Merge pull request #4776
6f5d33b Update translations after update script improvements (Wladimir J. van der Laan)
da59f28 Add deeper XML checking to update-translation script (Wladimir J. van der Laan)
Wladimir J. van der Laan [Thu, 28 Aug 2014 11:10:32 +0000 (13:10 +0200)]
Update translations after update script improvements
Wladimir J. van der Laan [Thu, 28 Aug 2014 11:09:19 +0000 (13:09 +0200)]
Add deeper XML checking to update-translation script
- Catch problems such as mismatched formatting characters. Remove
messages that can give problems at runtime.
- Also remove unfinished/untranslated messages, they just take up space
in the ts and waste parsing time.
Fixes #4774.
Wladimir J. van der Laan [Mon, 1 Sep 2014 07:41:50 +0000 (09:41 +0200)]
Merge pull request #4768
2e28031 Perform CVerifyDB on pcoinsdbview instead of pcoinsTip (Wladimir J. van der Laan)
Pieter Wuille [Wed, 20 Aug 2014 22:49:32 +0000 (00:49 +0200)]
Use CSizeComputer to avoid counting sizes in SerializationOp
Kamil Domanski [Wed, 20 Aug 2014 20:44:38 +0000 (22:44 +0200)]
rework overhauled serialization methods to non-static
Thanks to Pieter Wuille for most of the work on this commit.
I did not fixup the overhaul commit, because a rebase conflicted
with "remove fields of ser_streamplaceholder".
I prefer not to risk making a mistake while resolving it.
Kamil Domanski [Wed, 20 Aug 2014 16:09:29 +0000 (18:09 +0200)]
remove fields of ser_streamplaceholder
The nType and nVersion fields of stream objects are never accessed
from outside the class (or perhaps from the inside too, I haven't checked).
Thus no need to have them in a placeholder, whose only purpose is to
fill the "Stream" template parameter in serialization implementation.
Kamil Domanski [Wed, 20 Aug 2014 06:42:31 +0000 (08:42 +0200)]
overhaul serialization code
The implementation of each class' serialization/deserialization is no longer
passed within a macro. The implementation now lies within a template of form:
template <typename T, typename Stream, typename Operation>
inline static size_t SerializationOp(T thisPtr, Stream& s, Operation ser_action, int nType, int nVersion) {
size_t nSerSize = 0;
/* CODE */
return nSerSize;
}
In cases when codepath should depend on whether or not we are just deserializing
(old fGetSize, fWrite, fRead flags) an additional clause can be used:
bool fRead = boost::is_same<Operation, CSerActionUnserialize>();
The IMPLEMENT_SERIALIZE macro will now be a freestanding clause added within
class' body (similiar to Qt's Q_OBJECT) to implement GetSerializeSize,
Serialize and Unserialize. These are now wrappers around
the "SerializationOp" template.
Ross Nicoll [Sat, 2 Aug 2014 18:54:57 +0000 (19:54 +0100)]
Broken addresses on command line no longer trigger testnet.
When passing a bitcoin: URI on the command line, invalid addresses do not incorrectly send the
user to the test network.
Kamil Domanski [Thu, 7 Aug 2014 13:39:49 +0000 (15:39 +0200)]
changed field types in some structures to equivalent unambiguous types
Conflicts:
src/core.cpp
Rebased-By: Wladimir J. van der Laan
Github-Pull: #4180
Wladimir J. van der Laan [Sat, 30 Aug 2014 03:58:25 +0000 (05:58 +0200)]
Merge pull request #4789
bac5586 Replace weird characters by normal spaces (Pieter Wuille)
Pieter Wuille [Sat, 30 Aug 2014 00:38:23 +0000 (02:38 +0200)]
Merge pull request #4781
187115c cleanup include of assert.h (Philip Kaufmann)
Pieter Wuille [Sat, 30 Aug 2014 00:35:05 +0000 (02:35 +0200)]
Replace weird characters by normal spaces
Jeff Garzik [Sat, 30 Aug 2014 00:22:06 +0000 (20:22 -0400)]
Merge pull request #4778
Jeff Garzik [Sat, 30 Aug 2014 00:14:53 +0000 (20:14 -0400)]
Merge pull request #4788
This page took 0.067207 seconds and 4 git commands to generate.